ARB solenoid leaking oil

4x4JeePmaNthINg

New member
Just recently my solenoid started leaking oil. I believe it might be diff oil, stinks a little.

I haven't used my locker in ages so I find it out that there's oil leaking.
I know they can leak when bad, but again it hasn't been used this year.

I haven't check my breather tube yet, but I haven't been in anything that would clog it either.



Any other thoughts on what to check?
 

RCP Phx

New member
It's diff fluid, usually means there is leakage in the internal ARB seal at the diff. I would definitely check your breather vent.
 

4x4JeePmaNthINg

New member
Internal...? Any idea what gives or why, that's a bit odd for some thing hardly ever used.

The breath is not kinked, I didn't get either end off, they didnt seem to want to pull off the axle/frame freely. Frame side wobbles around a little, but this thing is deffinetly spitting up oil. Long drive today and there's more.

Should the hose pull off a barbed end axle side? How about frame? Didn't want to tear it
 

RCP Phx

New member
I have had my ARB for over 15yrs. I don't think anything is wrong, I've had the same thing happen. I would image that it's from non-use vs exercising it every once in a while as I have cleaned mine up with no damage found.
 

4x4JeePmaNthINg

New member
I'll remove the breather and check fully. It's seems this is possibly forcing oil up the air tube (if thats the issue).

I'll hook up the switches to cycle the locker on IF this isn't a big no no.

I did think I had a switch issue at one point, it would cycle the comp until the locker switch was selected. Originally the compressor would activate with its cirresponding switch and then you could choose the locker as needed. It still locked up once this change happened, but i don't know why it functions without this independent function as before.


Is the solenoid something I need to remove and clean before attempting to cycle the locker?
 

RCP Phx

New member
I don't understand your switch issue but I would pull the hose top and bottom and blow it out. There is not much you can do with the solenoid but spray it down.
 

RCP Phx

New member
Which compressor set-up do you have? Are you running a factory ARB wire harness? I'm still unclear as to what's been going on. When I push the compressor button it kicks in until it meets the pressure switch setting. It will not run again until a few uses of the locker or it will run continuously when I air my tires up.
 

4x4JeePmaNthINg

New member
Small ARB compressor, factory ARB harness/switches
When installed originally:
-hit compressor switch and it builds
-locker switch and it looks
Just like yours

The last time I was using it:
- hit compressor switch, nothing happens but leave pressed then
- hit locker switch, compressor runs a moment and locks- odd



Either way that's all like a year since it's been used, switches aren't even hooked up right now.


All I know is yesterday was the first time I've had fluid coming out of the solenoid and it did so all day, I had cleaned it before leaving and again once I got home.

Should the breather tube pull straight off?

After checking the breather and solenoid, should it be safe to try cycling on the compressor and locker?
 

4x4JeePmaNthINg

New member
Breather is clear throughout tube and ports to axle/body.

Pulled solenoid apart, wiped down and reinstalled.

Hooked switches up. Turned vehicle to run, but the compressor switch and it poped my stereo fuse????? For the love of god lol, this isn't making life easy.

Do bad switches take out the fuse typically?
 

4x4JeePmaNthINg

New member
iirc I don't think it came with relays? Two leads( tied into 15amp stereo power on, to power-switches- harness to comp(solenoid,pressure switch, comp ground)
 

4x4JeePmaNthINg

New member
Not sure what 5.9 Is?
Yes it's the cksa! Little guy


Only set up for rear locker, front is isolated and tied off. The stereo is a 15A circuit which is why it's taped into this. Any idea why the fuse would go?

My arb instructions has nothing on this haha.
 
Top