Hesitates and stalls

19xj87

New member
Run down. 97 cherokee 4.0 at 44wd. So was out hunting driving through snow and hit a bump in the road and a small ditch on other side hit pretty hard and instantly killed it. Long story short no spark no fuel. Eneded up getting towed home. Unpluged Frank sensor and let sit for a while plugged back in and fired up. Went out again next day ran fine all day till evening and died again on a smooth road. Long story short again repeated process multiple times and finally made it home. Replaced crank position sensor and it tires right up. Drove less than 3 miles to gas station and noticed every time I hit the throttle at all it hesitates and drops rpms and the runs good. Had no start again at gas station repeated process again and drove home. Any think that common cause?
 

19xj87

New member
Also just a note. The water temp gauge hasn't worked since hitting hard don't know if that ties in with the issue of not
 

Tim_MN

Freakish Hand Strength
NAXJA Member
Always buy genuine Jeep engine sensors, not cheap crappy Chinese clones with a "Lifetime Warranty". Just because you have a new CPS, does mean it is any good.

Suspect a loose wire plug, or a cut/pinched/melted/broken wire or wires. Fix any known issues such as the temp gauge.
 

19xj87

New member
Update. After tracing out wires and after replacing cps and replacing throttle position sensor and reparing wiring to tps. Found the issue in colant temp sensor got it working and jeep runs fine.
 
Top